iMovie 08 and mystery of disappearing Project Library

As if the yesterday’s Firmware update issue was not enough, I had very strange experience with iMovie 08. Suddenly, for no obvious particular reason the user interface became very unresponsive, I was not able to select project in project library. Switching Event library and Project windows on or off stopped working. Windows were not redrawn properly. Creating new project had no visible effect. I could not click on project to select it (well, technically I *could* click, but nothing happened). The time sliders in Events and Projects were either disabled or invisible …

Here is how the iMovie looked like most of the time:

I tried multiple things to fix that: Logout and re-login – no change. Reboot (remember, I came from Windows where this very often used remedy ;-)). No luck. Check and repair the permissions using Disk Utility. No improvement. Verify disk. No errors and still no improvements.

I even resorted to reinstallation of iLife 08. The only effect I achieved was that I got back trial version of Office 2004 which I deleted right after installing Leopard and had to download and install several updates for Garage Band and iWeb – but iMovie still did not work. Installation of iMovie HD (from iLife 06) worked OK as well did the iMovie 06 – but that was not much help because I did not want start from scratch and iMovie 08 with all its bad features is still able to accept way more input formats than ’06.

After killing well over three hours that was supposed to be spent on finishing the screencast, I started to delete all iMovie project files and even libraries from previous attempts. And suddenly, iMovie sprung to life and was as before.

I think that reason for the issues was moving the Events library for some of the older screencasts to external disk, but leaving the Project files in iMovie. Somehow this must have confused the program and the non-responsiveness could be caused by trying to connect the thumbnails and file references from the projects to the not available source clips from event library.

Lesson learned: whenever I move done an event library used in the screencast to external hard disk, it is probably safest to backup and remove the project as well. In other words – keep these two words separated and disjunct.

But of course – this can also be a pure coincidence and everything can have completely different cause. Time will tell. Too bad that Premiere Elements does not exist for Mac platform. Maybe I should seriously consider looking at Final Cut Express ?

Advertisements
Explore posts in the same categories: lifehacks, Mac, podcasts

Tags: , , ,

You can comment below, or link to this permanent URL from your own site.

6 Comments on “iMovie 08 and mystery of disappearing Project Library”

  1. Sarah Says:

    I need help. when i open some important saved projects in imovie, the clips are no longer in the clip panel. on one of them, i can see all the editing work i did down in the timeline, but it wont play. nothing is viewable. is this similar to what you experienced? any leads?

  2. Miro Says:

    Partially yes

    What I would try is:
    – backup your movie library (both iMovie events AND iMOvie projects) – close iMovie before
    – try to remove the OTHER iMovie projects one by one until it starts to work again

    Usually the problems like these are related to some corrupted movie project that does not load
    properly and causes iMovie to behave strange. Removing the offending project may help.

    Of course, if the important project is corrupted, you may have to start from scratch and create new project, add clips etc.

    Good luck

  3. Viv Says:

    Hi,

    I have a very similar problem…. but when you say backup your movie, what exactly do you mean? As I have only ever been able to see the movie in imovie. Does imovie physically create the movie file in a folder somewhere? I would appreciate any help anyone can offer as I have spent hours on this project.

  4. Miro Says:

    The folder would be /Users/USER-NAME/Movies/iMovie Projects.localized/MOVIE-NAME.rcproject

    Movie file is a package which means that Finder sees it as single file – which is what you want.
    In reality, it is a directory with lots of file underneath – right-click in Finder and select ‘Show Package Content’

    The events – clips to be processed are stored in
    /Users/USER-NAME/Movies/iMovie Events.localized folder

    Hope it helps

  5. Ysmael Says:

    Thanks so much! Miros I have to tell you are the best, I tried multiple things to fix my iMovie crash and nothing work no apple, no software can fix it but just delete all the folders in my iMovie and I have back.
    I follow your steps and works great!
    Maybe can help others, if you can not fix your iMovie tried to log in as other “User” and works also.
    Thanks again
    I run a Mac OS x 2.2 GhZ intel core duo
    iMovie 7.1.4(585)
    Gracias Miro!

  6. Carmen Says:

    I have a simmilar issue on a project I need to turn in 3 days. My movie was complete, is stored in an external disk. It opened perfectly but now I opened the project and 60% of the clips are not playing anymore. I opened the package and they are there but Imovie simply won’t open them. The audio plays too but not the images. What do you suggest I do?
    Should I unplug the external drive and erase all the files from my Imovie and then plug it again and try to open it?
    Should I erase the Imovie cache?
    Please help me!!! I’ve been working non-sleep on this project for weeks!


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: